Oil pressure issue.

More
1 year 6 days ago - 1 year 5 days ago #21571 by DirtDgr
DirtDgr created the topic: Oil pressure issue.
Ok guys. My car has been down since December WSOB race in San Felipe. Not good. I am really starting to have mental issues! I need to race big time. So here it goes. In the WSOB Mexicali to San Felipe race I had issues with fluctuating oil pressure. It started very early in the race, and plagued us all day until I finally had to call it quits.

So we would be humming along, car running perfect, and suddenly lose pressure. Then the guage would kinda fluctuate and go back to normal. Then it dropped and wouldn't come back up. Pulled over and oil is gushing out the passenger side valve cover. Big time.

So we fiddle around with the valve cover. I remove it and look in and all looks good. Add oil. Get back in the car and go. Seems good for awhile then does it again, and again, all day until we ran our chase out of oil and got to a point on the course where it was too risky to venture out and risk it. We had like one quart of oil left and a long ways to the next pit. So we turned back.

Temp was good all day. Ran great all day.

The car has not been touched since because I am afraid to mask the obvious if I start messing with it. But my plans of raiding the TwoLarrysRacing compound are sketchy for several reasons and if I can fix it I would love to do it.

I don't want to miss the problem and find out the hard way! If I just slap in a new oil pump, how do I know that's all it is?

Why is oil gushing from the(vented) valve cover?

I don't know where to start.

www.facebook.com/meekracing1142/
Thank You Lakeport Tire, Rugged Radios, Baja Designs, Sunoco, Two Larry's Racing
www.facebook.com/meekracing1142
Last Edit: 1 year 5 days ago by DirtDgr.

Please Log in or Create an account to join the conversation.

More
1 year 5 days ago #21573 by dirtslinger
dirtslinger replied the topic: Oil pressure issue.
You were losing that much oil out of the valve cover breather???

Please Log in or Create an account to join the conversation.

More
1 year 5 days ago #21574 by DirtDgr
DirtDgr replied the topic: Oil pressure issue.
Not out of the breather, sorry.


Just out the bottom of the valve cover, through the gasket. But it was intermittent.

We would add oil and be fine. The oil pressure would fluctuate up and down according to my gauge. But temps stayed good so I just continued on and took it kind of easy hoping to nurse it to a finish.

Then sometimes the needle would drop to nothing. Pull over and look. Oil pouring out the valve cover. Not just leaking. Gushing. I would remove valve cover and reinstall. Add oil. It would be fine for 5 miles or 30 miles. no pattern. Then do it again.

Its almost like pressure was building up somewhere if that is even possible.

www.facebook.com/meekracing1142/
Thank You Lakeport Tire, Rugged Radios, Baja Designs, Sunoco, Two Larry's Racing
www.facebook.com/meekracing1142

Please Log in or Create an account to join the conversation.

More
1 year 4 days ago #21575 by dirtslinger
dirtslinger replied the topic: Oil pressure issue.
Is it possible that the crankcase breather was clogged/blocked, and that you were getting a lot of crank case pressure from your valve guides or something like that?

Please Log in or Create an account to join the conversation.

More
1 year 4 days ago #21577 by michaelbrenner
michaelbrenner replied the topic: Oil pressure issue.
It may be simpler than you think, replace the bails with new OEM (not chrome) ones. Factory (brazilian) NOT empi crap; they aren't even the correct shape and they don't keep their tension. I fought this for awhile blowing out oil wondering why. I have seen a motor with lots of wear actually lift the covers off the heads at 5000rpm due to crankcase pressure and lousy parts. You may want to spring for some new OEM valvecovers, if they are slightly bent they will not seat correctly. Also, you must have a lot of crankcase pressure to blow oil out the valvecovers, rings and valves are suspect. The oil pump is probably not the issue unless it was simply assembled out of the box; shame on your engine builder, they need to be carefully measured and modified if you want great oil pressure with hot thin oil.

2013 SNORE Stock Bug Champs

Please Log in or Create an account to join the conversation.

More
1 year 1 day ago #21578 by DirtDgr
DirtDgr replied the topic: Oil pressure issue.

michaelbrenner wrote: It may be simpler than you think, replace the bails with new OEM (not chrome) ones. Factory (brazilian) NOT empi crap; they aren't even the correct shape and they don't keep their tension. I fought this for awhile blowing out oil wondering why. I have seen a motor with lots of wear actually lift the covers off the heads at 5000rpm due to crankcase pressure and lousy parts. You may want to spring for some new OEM valvecovers, if they are slightly bent they will not seat correctly. Also, you must have a lot of crankcase pressure to blow oil out the valvecovers, rings and valves are suspect. The oil pump is probably not the issue unless it was simply assembled out of the box; shame on your engine builder, they need to be carefully measured and modified if you want great oil pressure with hot thin oil.



Well I have never had a problem with the covers even dripping or leaking at all. Good used German stuff. Definitely an easy solution. But only way to find out is change it then race and hope for the best.

I think I will just camp out at the TwoLarryRacing compound and do a teardown of the engine. If it is from pressure building up, which at the time was my first guess, then it needs to be done anyhow. Thanks!

www.facebook.com/meekracing1142/
Thank You Lakeport Tire, Rugged Radios, Baja Designs, Sunoco, Two Larry's Racing
www.facebook.com/meekracing1142

Please Log in or Create an account to join the conversation.

More
1 year 4 hours ago #21579 by bugged
bugged replied the topic: Oil pressure issue.
are you venting the drivers side valve cover?

D.U.A.

Please Log in or Create an account to join the conversation.

More
11 months 4 weeks ago - 11 months 4 weeks ago #21580 by DirtDgr
DirtDgr replied the topic: Oil pressure issue.

bugged wrote: are you venting the drivers side valve cover?



Passenger side valve cover is vented on ours. Which is the side that gushed the oil.

We just added the vent at the start of last year too. Never had one before that. The issue I thought it was, at first during the race, was I thought the vent hose I ran to the valve cover was too tight. I was thinking the roughness of the course and car flexing and stuff might have been causing the hose to pull on the valve cover and move it slightly. I actually unbolted the breather and zip tied the crap out of it lower on the cage to give it more slack. I have never been on a course so consistently rough! Thought I fixed it....then it broke our hearts down the course a ways...again.

We found out after we stopped we actually had a chance to win WSOB at a point in the race as the two leaders were both broke at one point. DaveCo not far from where we called it quits was done for good. That stung a little.

Mexicali to San Felipe the car was run a lot harder than Caliente by far. Lots of soft sand. Even trying to take it easy was not easy!

Just going to tear it apart and find out.

Motor has all the WSOB races on it. So it is due for a tear down anyways I think.

www.facebook.com/meekracing1142/
Thank You Lakeport Tire, Rugged Radios, Baja Designs, Sunoco, Two Larry's Racing
www.facebook.com/meekracing1142
Last Edit: 11 months 4 weeks ago by DirtDgr.

Please Log in or Create an account to join the conversation.

Time to create page: 0.220 seconds